Un utente ha chiesto
Categoria: Simple Calendar – Google Calendar Plugin di WordPress
Domanda: Aggiornamento recente incompatibile con il plug-in “Galleria di Google Foto con shortcode”

Gli aggiornamenti recenti di Simple Calendar stanno rompendo gli album di foto sul mio sito web.

Sto utilizzando il plug-in “Galleria di foto di Google con codici brevi”
https://nl.wordpress.org/plugins/google-picasa-albums-viewer/

Con il semplice calendario abilitato ottengo questo errore:
Errore irreversibile: impossibile dichiarare la classe Google_Exception, perché il nome è già utilizzato in /home/sussudio/domains/sussudio.nl/public_html/wp-content/plugins/cws_google_picasa_pro/includes/api-libs/Google/Exception.php nella riga 18

La disabilitazione di Simple Calendar risolve gli errori irreversibili.

Ho visto altri commentare l’incompatibilità con altri plugin che usano google-api e alcuni di loro hanno indicato google-calendar-events.3.1.33 come soluzione.
Quindi ho effettuato il downgrade a 3.1.33 e in effetti questo risolve i miei errori fatali.

Potete indagare ed eventualmente correggere queste incompatibilità?

La pagina per cui ho bisogno di aiuto: [log in to see the link]

  • (@nhtechgal)

    Ho la stessa identica combinazione. È molto difficile scegliere tra nessun calendario e nessuna galleria!

    (@nhtechgal)

    Grazie per i consigli sul downgrade. Ho effettuato il downgrade poche ore fa e finora sembra essere stabile. Ecco il link se qualcuno ne ha bisogno:

    https://downloads.wordpress.org/plugin/google-calendar-events.3.1.33.zip

    Si spera che uno degli sviluppatori risolva presto il conflitto (anche se sembra che SC sia il problema più grande, con potenziali conflitti con Updraft e altri plugin).

    (@flojflorian)

    Grazie mólto. Ho avuto lo stesso problema e ho eseguito il downgrade a https://downloads.wordpress.org/plugin/google-calendar-events.3.1.33.zip e funziona di nuovo senza problemi. Spero che in futuro non ci saranno più conflitti tra questi due plugin.

    (@dennispiet)

    Poiché non c’erano risposte da Simplecalendar in questo forum di supporto, li ho contattati tramite il loro sito web. Li ho indirizzati a questo forum e ho chiesto loro di leggere per favore diverse persone che hanno problemi con Simplecalendar in combinazione con altri plugin che utilizzano google api.

    Ora stanno chiedendo l’accesso wp-admin sul mio sito Web per testare. Mi sembra che potrebbero facilmente eseguire il debug di questo sul proprio sito di test.

Hai risolto il tuo problema?

0 / 0

Lascia un commento 0

Il tuo indirizzo email non sarà pubblicato. Required fields are marked *