Un utente ha chiesto
Categoria: Affiliate Super Assistent di WordPress
Domanda: ASA2 non compatibile con AMP di Automattic e AMPforWP

Ciao squadra,

Sono uno degli sviluppatori AMPforWP perché sappiamo che hai aggiunto la funzionalità AMP Compatible nel tuo plug-in “Amazon Simple Affiliate (ASA 2)” ma dopo l’aggiornamento ad AMP di Automattic versione 0.70. e anche con la nostra versione di 0.9.94 crea errori di convalida ‘amp-custom style’ che appaiono più di una volta.

In questo momento suggeriamo ai nostri utenti di disattivare questa funzione AMP in modo che ti suggeriamo di renderla compatibile con il nostro plug-in e, se hai bisogno di aiuto per farlo, siamo felici di collaborare e assicurarci che entrambi i nostri plug-in funzionino perfettamente l’uno con l’altro.

  • Autore del plugin

    (@worschtebrot)

    Grazie per il tuo feedback. Il problema è che attualmente sta creando più tag amp-custom, il che non è valido. Il prossimo aggiornamento risolverà questo problema. Fino ad allora, c’è un’opzione per disabilitare la funzionalità AMP in ASA2. La correzione verrà rilasciata a breve.
    Quale pensi sarebbe il modo migliore per aggrapparti allo stile personalizzato dell’amplificatore e aggiungere il tuo CSS?

    (@sejiro)

    Ciao @worschtebrot,

    Grazie per l’attenzione, è bello sapere che il prossimo aggiornamento avrà una tale funzionalità.
    il modo migliore per aggiungere CSS per AMP è utilizzare il seguente hook amp_post_template_css

    e assicurati che l’unico CSS richiesto sia caricato tramite le condizioni per garantire che il CSS non sia più grande di 50 KB.

Hai risolto il tuo problema?

0 / 0

Lascia un commento 0

Il tuo indirizzo email non sarà pubblicato. Required fields are marked *