Un utente ha chiesto
Categoria: WP Recipe Maker di WordPress
Domanda: Errore nella compatibilità di yoast

Ciao

Il mio sito di prova funziona:
– WP 5.4
– WP Ricetta Maker 5.11.1
– Lievito 13.4.1

e nel pannello di amministrazione ottengo:
“Errore di sintassi: flag di espressione regolare non valido” in yoast-compatibility.js qui


data = data.replace(/<!-- wp:wp-recipe-maker/recipe.*?/wp:wp-recipe-maker/[^s]* -->/gms, '');

dopo aver rimosso il flag s, tutto funziona correttamente.

  • Autore del plugin

    (@brechtvds)

    In realtà, non ho questo problema con questa stessa combinazione di versioni. Per quanto ne so, s è anche un valido indicatore regex.

    Che browser (e versione) stai utilizzando?

    (@palmiak)

    Ciao @brechtvds

    Sto usando l’ultimo Firefox – in Chrome questo problema non esiste.

    Dai un’occhiata qui https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/RegExp – Il flag dotAll non funziona su FX.

    Autore del plugin

    (@brechtvds)

    Interessante. Lo guarderò per il prossimo aggiornamento. Per quanto ne so da un test rapido, questo non interrompe alcuna funzionalità. O rompe le cose per te?

    (@palmiak)

    Penso che sia indistruttibile o almeno nel mio caso non si è rotto nulla.

    Ma se possibile, è sempre meglio sbarazzarsi di bug come questo.

    Grazie ancora per una rapida risposta.

    Autore del plugin

    (@brechtvds)

    Ciao di nuovo,

    Abbiamo appena rilasciato WP Recipe Maker 6.0.0 che dovrebbe risolvere questo problema. Grazie ancora per avermelo fatto sapere!

Hai risolto il tuo problema?

0 / 0

Lascia un commento 0

Il tuo indirizzo email non sarà pubblicato. Required fields are marked *