Un utente ha chiesto
Categoria: Foyer – Digital Signage for WordPress di WordPress
Domanda: Le immagini non compaiono nei post (Gutenberg)

Quando si aggiungono immagini a un post utilizzando l’editor Gutenberg predefinito. La diapositiva mostra solo un piccolo segnaposto bianco.
Quando si utilizza l’editor classico, tutto funziona correttamente.

Ho notato in CSS (debug Chrome F12) che l’altezza dell’immagine è impostata su 0 quando si utilizza l’editor Gutenberg.

Impossibile fornire un collegamento a causa di un ambiente vuoto.

  • Autore del plugin

    (@mennolui)

    Hoi @watskebart,

    Questo non dovrebbe accadere ovviamente 🙂 Ho provato con i contenuti di Gutenberg e non ho riscontrato problemi. Quindi qualsiasi aiuto per riprodurre questo problema è apprezzato!

    Potresti inviarmi uno screenshot della diapositiva problematica, nonché uno screenshot della finestra di debug di Chrome? Quale versione di WordPress, quale tema e quali plugin stai utilizzando? Potresti provare a vedere cosa succede con il tema Twentynineteen o vingttwenty abilitato al posto del tema scelto e con tutti i plugin disabilitati? Fammi sapere cosa trovi e lo prenderemo da lì.

    Meglio,
    Menno

    (@watskebart)

    Ho appena usato l’editor classico.

    Screenshot in un articolo quando si utilizza Gutenberg:
    Immagine dello schermo

    Schermata Chrome F12:
    Schermata F12

    Screenshot Chrome F12 ha modificato manualmente l’altezza da 0 a 300:
    Schermata di modifica manuale F12

    Autore del plugin

    (@mennolui)

    Ciao @watskebart, grazie per gli screenshot! Hai trovato quale regola CSS fa apparire l’elemento come altezza 0? E da dove viene questo CSS (ad esempio, si trova in un file CSS principale di WordPress, o in un file CSS di plug-in o in un file CSS di temi)? Queste informazioni devono essere visibili negli strumenti di sviluppo F12. Sarebbe interessante saperlo. Se è molto comune (ad esempio il core di WordPress), forse posso risolverlo in Focus.

    Puoi anche provare a vedere cosa succede con il tema Twentynineteen o vingttwenty abilitato al posto del tema scelto e con tutti i plugin disabilitati. Questo mi dirà se è un tema o un plug-in che impedisce la visualizzazione dell’immagine o qualcosa di più generale.

    grande!

    (@songmk)

    Ho lo stesso problema. Ho installato solo un nuovo WordPress e Hearth. Nel mio caso è lo stesso risultato di entrambi gli editor

    WP: 5.3.2
    Tema: venti e venti

    Autore del plugin

    (@mennolui)

    Ciao @watskebart e @songmk, sono stato in grado di riprodurlo e lo risolverò nella prossima versione di bugfix di Foyer.

    Grazie per la segnalazione!

Hai risolto il tuo problema?

0 / 0

Lascia un commento 0

Il tuo indirizzo email non sarà pubblicato. Required fields are marked *