Un utente ha chiesto
Categoria: LMS by LifterLMS – Online Course, Membership & Learning Management System Plugin for WordPress di WordPress
Domanda: l’ultimo aggiornamento rompe gutenberg

Ciao
Prima di tutto, complimenti per questo incredibile LMS. Non solo è il migliore sul mercato, ma è molto flessibile e secondo me ben supportato.

Solo una cosa con l’ultimo aggiornamento (3.37.4), in uno dei miei siti ha rotto gutenberg (editor di blocchi) in un set di strumenti creato CPT. In sostanza, non ha caricato l’editor di blocchi, anche per i post creati in precedenza. Il downgrade di LifterLMS alla versione 3.37.3 ha risolto il problema.
Per me è risolto, rimarrò solo in questa versione, se vuoi eseguire il debug di questo per altri utenti, posso darti l’accesso al sito di staging.

Cordiali saluti,
Alexis

Di seguito sono riportati gli errori dell’editor di blocchi, con e senza jetpack e con dominio *****:

Errore: si è verificato un errore durante l’esecuzione di “mapSelect”: impossibile leggere la proprietà non definita “_llms_form_location”
L’errore può essere correlato a questo errore precedente:
TypeError: impossibile leggere la proprietà non definita ‘_llms_form_location’
Per https: //********/wp-content/plugins/lifterlms/vendor/lifterlms/lifterlms-blocks/dist/blocks.build.js: 1: 274088

in Object.current (https://c0.wp.com/c/5.3/wp-includes/js/dist/data.min.js:1:19491)
a t (https://c0.wp.com/c/5.3/wp-includes/js/dist/data.min.js:1:19116)
Per https://c0.wp.com/c/5.3/wp-includes/js/dist/data.min.js:1:19283

Per https://c0.wp.com/c/5.3/wp-includes/js/dist/data.min.js:1:15212

su Array.forEach ()
pure (https://c0.wp.com/c/5.3/wp-includes/js/dist/data.min.js:1:15184)
Per https://c0.wp.com/c/5.3/wp-includes/js/dist/data.min.js:1:13576

superiore (https://c0.wp.com/c/5.3/wp-includes/js/dist/data.min.js:1:6765)
Per https://c0.wp.com/c/5.3/wp-includes/js/dist/redux-routine.min.js:1:9535

Per https://c0.wp.com/c/5.3/wp-includes/js/dist/data.min.js:1:8752

su Object.dispatch (https://c0.wp.com/c/5.3/wp-includes/js/dist/data.min.js:1:9187)
Per https://c0.wp.com/c/5.3/wp-includes/js/dist/data.min.js:1:13063

a s (https://c0.wp.com/c/5.3/wp-includes/js/dist/data.min.js:1:23560)
su Generator._invoke (https://c0.wp.com/c/5.3/wp-includes/js/dist/data.min.js:1:23348)
a Generator.forEach.t. [as next] (https://c0.wp.com/c/5.3/wp-includes/js/dist/data.min.js:1:23983)

Traccia della batteria originale:
a Tt (https://c0.wp.com/c/5.3/wp-includes/js/dist/data.min.js:1:18925)
Per https://c0.wp.com/c/5.3/wp-includes/js/dist/data.min.js:1:19466

a me (https://c0.wp.com/c/5.3/wp-includes/js/dist/vendor/react-dom.min.js:78:476)
a qe (https://c0.wp.com/c/5.3/wp-includes/js/dist/vendor/react-dom.min.js:89:115)
al ph (https://c0.wp.com/c/5.3/wp-includes/js/dist/vendor/react-dom.min.js:216:489)
A sinistra (https://c0.wp.com/c/5.3/wp-includes/js/dist/vendor/react-dom.min.js:126:409)
pure (https://c0.wp.com/c/5.3/wp-includes/js/dist/vendor/react-dom.min.js:121:71)
ze (https://c0.wp.com/c/5.3/wp-includes/js/dist/vendor/react-dom.min.js:118:14)
Per https://c0.wp.com/c/5.3/wp-includes/js/dist/vendor/react-dom.min.js:53:49

su unstable_runWithPriority (https://c0.wp.com/c/5.3/wp-includes/js/dist/vendor/react.min.js:26:340)
a mamma (https://c0.wp.com/c/5.3/wp-includes/js/dist/vendor/react-dom.min.js:52:280)
in mg (https://c0.wp.com/c/5.3/wp-includes/js/dist/vendor/react-dom.min.js:52:496)
a V (https://c0.wp.com/c/5.3/wp-includes/js/dist/vendor/react-dom.min.js:52:431)
a Sb (https://c0.wp.com/c/5.3/wp-includes/js/dist/vendor/react-dom.min.js:213:96)
a mg (https://c0.wp.com/c/5.3/wp-includes/js/dist/vendor/react-dom.min.js:85:80)
a t (https://c0.wp.com/c/5.3/wp-includes/js/dist/data.min.js:1:19197)

Errore: si è verificato un errore durante l’esecuzione di “mapSelect”: impossibile leggere la proprietà non definita “_llms_form_location”
L’errore può essere correlato a questo errore precedente:
TypeError: impossibile leggere la proprietà non definita ‘_llms_form_location’
Per https://hub.pme-digital.pt/wp-content/plugins/lifterlms/vendor/lifterlms/lifterlms-blocks/dist/blocks.build.js:1:274088

in Object.current (https: //********/wp-includes/js/dist/data.min.js: 1: 19491)
a t (https: //********/wp-includes/js/dist/data.min.js: 1: 19116)
Per https: //********/wp-includes/js/dist/data.min.js: 1: 19283

Per https: //h********/wp-includes/js/dist/data.min.js: 1: 15212

su Array.forEach ()
pure (https: //********/wp-includes/js/dist/data.min.js: 1: 15184)
Per https: //********/wp-includes/js/dist/data.min.js: 1: 13576

superiore (https: //********/wp-includes/js/dist/data.min.js: 1: 6765)
Per https: //********/wp-includes/js/dist/redux-routine.min.js: 1: 9535

Per https: //********/wp-includes/js/dist/data.min.js: 1: 8752

su Object.dispatch (https: //********/wp-includes/js/dist/data.min.js: 1: 9187)
Per https: //***********/wp-includes/js/dist/data.min.js: 1: 13063

a s (https: //***************/wp-includes/js/dist/data.min.js: 1: 23560)
su Generator._invoke (https: //***********/wp-includes/js/dist/data.min.js: 1: 23348)
a Generator.forEach.t. [as next] (https: //********/wp-includes/js/dist/data.min.js: 1: 23983)
……

  • (@ emilymoran84)

    Solo per supportare questo, ho avuto lo stesso problema ed errore (anche se non sono sicuro di come ripristinare una versione precedente del plug-in).

    Autore del plugin

    (@thomasplevy)

    @emilymoran84 e @apessoa

    Terribilmente dispiaciuto per questo… Il codice in esecuzione qui dovrebbe essere eseguito solo su un tipo di post LifterLMS, ma abbiamo il controllo condizionale per quello nel posto sbagliato.

    Abbiamo registrato il problema nel nostro repository GitHub su https://github.com/gocodebox/lifterlms-blocks/issues/40

    Puoi seguire lì se vuoi risultati specifici o maggiori informazioni sul bug stesso.

    Spero di poter risolvere il problema in una versione entro la fine della giornata, ma potrebbe non essere così fino a domani.

    Grazie per la segnalazione e grazie per la pazienza.

    Per tutto ciò che vale, se il tuo tipo di post personalizzato * supporta * campi personalizzati, penso che questo problema scomparirà. Se sei in grado di cambiarlo, puoi farlo senza dover aspettare il nostro prossimo aggiornamento per chiudere il bug.

    Meglio,

    Autore del plugin

    (@thomasplevy)

    @ emilymoran84 e @apessoa,

    La versione 3.37.5 correggerà questo bug. Per favore, fai un aggiornamento e fammi sapere se hai altri problemi o domande.

    Meglio,

    (@ emilymoran84)

    @thomasplevy Grazie mille per la rapida risposta e la correzione! Le cose ora sono di nuovo operative 🙂 Molto apprezzato!

    Autore del plugin

    (@thomasplevy)

    @ emilymoran84

    Felice di sentirlo!

Hai risolto il tuo problema?

0 / 0

Lascia un commento 0

Il tuo indirizzo email non sarà pubblicato. Required fields are marked *