Un utente ha chiesto
Categoria: Contact Form 7 di WordPress
Domanda: Modulo di contatto 7 incompatibile con PHP 7.4

Ciao,

Sono un grande fan del tuo plug-in Contact Form 7. Va bene. Tuttavia, ho notato che lo è non compatibile con la versione finale di PHP 7.4.

Ecco alcune informazioni aggiuntive.
– L’intero sito, con tutti i plugin attivati, funziona perfettamente su PHP 7.3. Quando aggiorno a PHP 7.4, la chiamata “feedback” dei moduli restituisce il seguente errore:
{"into":"#wpcf7-f886-p9-o1","status":"mail_failed","message":"Er is een fout opgetreden bij het versturen van het bericht. Probeer later nog een keer."}

– Attualmente ho attivato i seguenti plugin: Akismet, Contact Form 7, Google Analytics Dashboard for WP, NextGEN Gallery, Shortpixel Image Optimizer, Swap Google Fonts Display, W3 Total Cache, WhatsApp Chat, WP-Optimize e Yoast SEO
– Ho già provato a disattivare gli altri plugin e ad attivare solo il tuo. Questo non sembra fare il trucco, purtroppo. Tornare a PHP 7.3 sembra essere l’unica cura.

Spero di essere stato abbastanza utile!

  • Autore del plugin

    (@takayukister)

    Duplicato – https://wordpress.org/support/topic/contact-form-7-incompatible-with-php-7-4-2/

    Autore del plugin

    (@takayukister)

    Dove possiamo vedere il sito web?

    (@mvanturnhoutziggonl)

    Il sito si trova attualmente su https://www.mastepinnelaand.nl e lavorando di nuovo su PHP 7.3, perché non posso permettermi i moduli in questo momento.

    A proposito, non sono un grande fan della divulgazione degli URL, per motivi di privacy e sicurezza. Mi manca un’opzione di messaggio privato qui.

    Autore del plugin

    (@takayukister)

    Vedi https://wordpress.org/support/topic/welcome-to-support-forum-please-read-before-posting/

    (@mvanturnhoutziggonl)

    Va bene ho capito. Nessun problema, puoi visitare il sito 🙂

    (@cipriandoftei)

    @takayukister, @mvanturnhoutziggonl Ho lo stesso problema. Su PHP 7.3, tutto funziona bene. Dopo l’aggiornamento a PHP 7.4, Contact Form 7 smette di funzionare.

    Hai trovato una soluzione a questo?

    (@mvanturnhoutziggonl)

    Spero solo che @takayukister aggiorni il plugin per renderlo compatibile con PHP 7.4 🙂

    (@rudolph-smits)

    @takayukister

    caro Signore

    Se hai bisogno di un sito con php 7.4 abilitato per vedere e risolvere il problema, sono pronto a suggerirti di avere 7.4 attivo sul mio sito in un giorno che menzioni. Dopo quel giorno, riattiverò php 7.3. Questo potrebbe aiutarti?

    Piazzare http://www.magoster.nl attualmente funziona su php 7.3.
    È tutto in olandese, ma potrei essere in grado di aiutarti a fare una (falsa) prenotazione.

    Saluti
    Rudolph Smits, Paesi Bassi

    (@alios24)

    Ho lo stesso problema, sono tornato a 7.2 🙁

    (@ayxaaron)

    Ciao, può supportare php 7.4 ora? Ho bisogno della velocità maggiore @takayukister

    (@pca2014)

    Ho lo stesso problema. Non funziona con PHP 7.4. Ho dovuto tornare a PHP 7.3

    (@mvanturnhoutziggonl)

    Ragazzi, falso allarme. Ho fatto alcune ricerche e si è scoperto che PHP 7.4.1 era il problema. Un bug nel sistema di messaggistica. A partire da PHP 7.4.2 tutto funziona correttamente.

    (@pca2014)

    Qualcuno sa se PHP 7.xx è stato corretto?

    (@pca2014)

    Non ho avuto fortuna con PHP 7.4.2 (credo versione pessima) ma va tutto bene utilizzando PHP 7.4.5 con l’ultima versione di WordPress 5.4.1 su tre diversi siti Web, tutti con temi diversi. Chiaramente non è un problema di Contact 7.

    (@craighopee)

    @ pca2014 ho avuto lo stesso problema .. era strano se reinstallassi wordpress wp-includes e wp-admin .. avrebbe funzionato per alcuni giorni poi smetteva di funzionare ..

Hai risolto il tuo problema?

0 / 0

Lascia un commento 0

Il tuo indirizzo email non sarà pubblicato. Required fields are marked *