Un utente ha chiesto
Categoria: Smartline Lite di WordPress
Domanda: SL Lite 1.6 e WP 5.1 Gutenberg

Buongiorno,
Congratulazioni per il tuo eccellente tema SmartLine Lite.

Attualmente sto riscontrando alcuni problemi con (credo) dall’aggiornamento da WP 4.9.9 a WP 5.0 – 5.0.3 e infine 5.1 alcuni giorni fa, MA solo quando si utilizza Gutenberg.

Dal momento che non mi piace molto Gutenberg, ho installato il plug-in Classic Editor dopo l’aggiornamento a WP 5.0. Da allora, il mio editor predefinito è Classic Editor / TinyMCE Advanced.

A scopo di test, ho scritto un singolo articolo usando Gutenberg (guarda questo link). Era un vero problema farlo, per niente flessibile. È molto meno conveniente dell’editor classico.

PB-1. Ora, usando Gutenberg, ho provato a inserire questo articolo nello slider della home page della mia rivista, ma senza fortuna. Il mio tag “SLIDER” non è affatto riconosciuto da Gutenberg. E anche forzando SLIDER come nuovo tag, il risultato è sempre lo stesso. Questo articolo non è presente nel cursore della pagina della mia rivista.
Fare lo stesso con l’editor Classic funziona ancora alla grande con tutti i miei post scritti prima e dopo WP 5.0.

PB-2. Sempre con lo stesso articolo, utilizzando Gutenberg per aggiungere un blocco Button, la gamma di possibilità sembra limitata da SmartLine.

Cosa ne pensi ? Questi problemi sono dovuti a SmartLine/Gutenberg o riguardano solo WP/Gutenberg?

Qualsiasi aiuto sarà molto apprezzato.
Grazie.

La pagina per cui ho bisogno di aiuto: [log in to see the link]

  • (@ joe76000)

    Buongiorno,
    Ho fatto altri test ma ancora lo stesso problema con il post slider che non funziona con WP 5.0 – 5.1 e Gutenberg.

    1. Alla riapertura dell’articolo sopra citato scritto con WP 5.1 e Gutenberg, il tag SLIDER che ho forzato è sparito. E quando si inserisce SLIDER lettera per lettera, solo la coppia SL offre tag già esistenti. MA nessun tag SLIDER.

    2. Così ho creato un nuovo articolo molto semplice con i seguenti passaggi.
    – Nuovo articolo -> Inserisci un titolo -> Inserisci testo -> Inserisci il tag SLIDER che è stato subito e ben riconosciuto -> Conferma dell’inserimento del tag -> Passa dall’editor classico a Gutenberg.
    – Controllato il tag (s) già inserito -> NIENTE -> E ridigitare SLIDER lettera per lettera, ma solo e ancora SL offre tag già esistenti. MA nessun tag SLIDER.

    Quindi è chiaro che da qualche parte c’è un’incompatibilità tra WP 5.1 + Gutenberg + SmartLine Lite 1.6. La domanda è dove e perché? Cosa c’è che non va? “SLIDER”-my-tag ora è una parola riservata al sistema WP 5.x + Gutenberg?

    Per anni, la mia configurazione è stata la seguente e funziona senza problemi anche con WP 4.9.9 (TinyMCE Advanced) + SmartLine Lite 1.6 (mira a WP 5.0):
    – SmartLine Lite -> Opzioni tema -> Post Slider
    – Attiva Post Slider con entrambe le linee selezionate
    – Nome tag -> SLIDER
    – Nascondi il tag nella nuvola di tag selezionato

    Grazie.

    (@ joe76000)

    Buongiorno,
    Dopo ulteriori test ho trovato una soluzione.

    La modifica del nome del tag per il cursore del post non è migliore. Qualunque sia il nome del tag, il problema è ancora lì.

    In effetti, il colpevole è SmartLine Lite 1.6 che non è completamente compatibile con l’editor Gutenberg di WordPress 5.0 – 5.1

    => LA MIA soluzione era -NO- Nascondi il tag nel tag cloud; vale a dire deselezionata questa linea!
    Ora il mio problema è risolto.

    Saluti

    (@themezee)

    Ciao,

    Grazie per avermelo fatto notare, ma purtroppo non sono in grado di ricostruire questo problema in questo momento. Lo slider funziona ancora bene con WordPress 5.0 e Gutenberg su tutti i miei siti di test.

    L’editor Gutenberg è solo la nuova interfaccia utente per l’aggiunta di contenuti, inclusi i tag. Il cursore funziona completamente all’esterno dell’editor e il tag viene prelevato direttamente dal database. Non importa se è entrato nel database con l’editor classico o con l’editor Gutenberg.

    Tuttavia, potrebbero esserci altre modifiche con WordPress 5.0 che potrebbero aver causato questo, ma l’editor Gutenberg non è il problema.

    Meglio,
    Thomas

Hai risolto il tuo problema?

0 / 0

Lascia un commento 0

Il tuo indirizzo email non sarà pubblicato. Required fields are marked *